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Chapter 1. Preface

This chapter gives an introduction to RCE.

1.1. Abstract

RCE (Remote Component Environment) is an open source software that helps engineers, scientists
and othersto create, manage and execute complex cal culation and simulation workflows. A workflow
in RCE consists of components with predefined inputs and outputs connected to each other. A
component can be asimulation tool, atool for dataaccess, or auser-defined script. Connections define
which data flows from one component to another. There are predefined components with common
functionalities, like an optimizer or a cluster component. Additionally, users can integrate their own
tools. RCE instances can be connected with each other. Components can be executed locally or on
remote instances of RCE (if the component is configured to alow this). Using these building blocks,
use cases for complex distributed applications can be solved with RCE.

1.2. Intended audience

This document isintended for devel opers who would like to extend RCE according to their needs and/
or contribute to RCE's development.

1.3. License Information

RCE is published under the Eclipse Public Licence (EPL) 1.0. It is based on Eclipse RCP 4.8.0
(Photon), which is also published under the Eclipse Public Licence (EPL) 1.0. RCE also makes use
of various libraries which may not be covered by the EPL; for detailed information, see the file
"THIRD_PARTY" in the root folder of an RCE installation. (To review this file without installing
RCE, open the RCE release .zip file.)

For downloads and further information, please visit https.//rcenvironment.de/.

1.4. Compatible Operating Systems

RCE releases are provided for Windows and Linux. It isregularly tested on
* Windows 7

* Windows 10

* Windows Server 2016

* CentOS7

* Debian9

e SUSE Linux Enterprise Desktop ("SLED") 12 SP2



https://rcenvironment.de/
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1.4.1.

1.4.2.

* Ubuntu 18.04LTS

Support of 32 Bit Operating Systems

Starting with release 8.0.0, RCE is only shipped for 64 bit systems. If you still require 32 bit packages,
you can continue to use previous RCE releases, but there will be no standard feature or bugfix updates
for them.

Known Issues

1.4.2.1. KDE on Red Hat Enterprise Linux 7

On Red Hat Enterprise Linux 7 with KDE 4, RCE (like any other Eclipse-based application) can cause
asegmentation fault at startup. If you encounter such an issue, you can try choosing adifferent GTK2
theme:

1. Open the System Settings application (systemsettings).
2. Goto Application Appearance
3. Open GTK page

4. Switch the GTK2 theme to "Raleigh” or "Adwaita" and click on Apply

1.4.2.2. KDE with Oxygen

On Unix Systems using KDE as desktop environment and Oxygen as theme it can happen that RCE
crashes when certain GUI elements are shown. It is a known issue in the theme Oxygen and happens
on other Eclipse-based applications as well. If you encounter such an issue, please choose a different
theme like "Raleigh” or "Adwaita’.

1.4.2.3. Jython scripts are executed sequentially

The Script component can use Jython for the evaluation of scripts and the pre- and postprocessing of
integrated tool s always uses Jython. Dueto aknown bug in the Jython implementation it isnot possible
to execute several Jython instances in parallel. Therefore, the execution will be done sequentialy. If
several Script components should be executed in parallel, Python should be used instead.

1.4.2.4. 32-bit Java is not supported

Running RCE with a 32-bit Java Runtime Environment doesn't work. On some operating systems an
error dialog will be displayed in this case, on some other systems nothing will happen at all. Therefore,
always make sure a 64-bit Java Runtime Environment is used to run RCE.




Chapter 2. Introduction

2.1. Getting Started with RCE development

This section covers setting up a devel opment environment for running, modifying and extending RCE
on your local machine.

2.1.1. Preparing Eclipse

» Make sure you have a Java Development Kit [http://www.oracle.com/technetwork/javaljavase/
downloads/index.html], Version 8ul61 or higher, installed on your system.

Note

If you areinstalling a JDK on a centrally administered computer that already has Javainstalled, it is usualy a
good idea to uncheck the "Install public JRE" option during installation.

Currently, Oracle JDK 8.x is the reference development platform. In the near future, however, this
will most likely be replaced by OpendDK on both Windows and Linux to simplify licensing issues.
OpenJDK has aready been successfully tested in version 8 and 11, on Windows and Linux, for
development and building. Note that automated JUnit test execution as part of the build processis
currently only possible with 8.x versions of the JDK; thiswill be extended to JDK 11 soon.

» Download and run "Eclipse for RCP/RAP Developers', Version "Photon (4.8.x)" or later from
https://www.eclipse.org/downloads/. Using the latest Eclipse release instead is usudly fine;
however, there may be slight differences between this guide and that version's Ul.

» Adapt your eclipse.ini file (see http://wiki.eclipse.org/Eclipse.ini for details):

 Set the proper path to your JDK installation (the - vmparameter; e.g. <your pat h>/j dk8/
bi n immediately below the - vmling).

¢ Change the maximum heap size to at least 2 GiB (adapt the - Xnmx line somewhere below -
vimar gs, e.g. to- Xnx2048m or add it if it does not exist yet)

* In the eclipse preferences (avaible from "Window"-> "Preferences’), open the page "Plugin-
Development" -> "DS Annotations' and check the box for "Generate descriptors for annotated
sources." Set the descriptor directory to "OSGI-INF/generated".

» Optiondly, install these plugins (for example using "Help > Eclipse Marketplace"):

« Workspace Mechanic [https://code.google.com/aleclipsel abs.org/p/workspacemechanic/] - used
to apply common workspace settings. Not strictly required, but convenient.

e Checkstyle-CS [http://eclipse-cs.sourceforge.net/] - Eclipse integration for Checkstyle (version
6.19 or above; see the note in section "Configuring CheckStyle" ). Not required for local
development, but mandatory before committing changes into the central code base.

2.1.2. Importing and building RCE

« If you already have other projects in your Eclipse workspace, it is recommended to create a new
workspace for RCE. There are some necessary global settings that may interfere with the other
projects (e.g. the so-called "target platform").
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» Disable "Project > Build Automatically" in the main menu to speed up the next steps.

» There are currently three ways to properly import the complete RCE source code: from the SVN
repository, from provided zip files, or from GitHub. At the moment, only the SVN approach
provides access to the current development tree; for the time being, the zip files and the GitHub
repository are only updated on release.

Option 1 - Importing from the RCE SVN repository, if you have access to it (as the repository is
currently hosted internally at DLRY):

e Install Subclipse [http://subclipsetigrisorg/] (or alternatively Subversive [http:/
www.polarion.com/products/svn/subversive.php]) if you don't already have an Eclipse SVN
plugin installed. Note that when using Subclipse, you may have to switch to the "SvnKit" SVN
interface in the "Team > SVN" preferences; thisisnormal.

* Openthe"SVN Repositories' view (Window > Show View > Other > SVN).

e Add https://svn.sistec.dlr.de/svn/rce/new rce/trunk as a new SVN
repository location.

« Expand the location entry and select all projects (the entries starting with "de.rcenvironment™)
inside of it.

» Right-click the selected projects, select "Checkout" and confirm if necessary. Y ou should now
see along list of projectsin the "Package Explorer” on the left.

Note

If the checkout was performed correctly, there should be asmall "M" (for "Maven") on most projects' icons,
and also asmall "J* (for "Java') on most of them.

» Option 2 - Importing from the zip files provided with each release:

e Browse to the "source” sub-folder of a release’'s download
location, for example ht t ps: // sof t ware. dl r. de/ updat es/ r ce/ 8. x/ product s/
standard/ rel eases/ 8. 1. 0/ sour ce/ for the 8.1.0 release. Download both zip files,
"source" and "additions"; the latter contains binary artifacts like the Dakota and TiGLViewer
executables.

« Extract both archives into the same target directory. Y ou should see alist of more than 200 sub-
folders, al except one beginning with "de.rcenvironment".

« In Eclipse, select "File > Import > Genera > Existing Projects into Workspace" and choose the
directory that you unpacked the archivesinto. Y ou should see along list of projects, once again,
all except one beginning with "de.rcenvironment”. Select all projects confirm the import.

Note

Make sure not to change the " Search for nested projects' option in theimport dialog; it must not be selected/
checked.

e Option 3 - Importing from GitHub:
 For successfully importing the RCE project, you need a Git client with LFS support.

e Clonehttps://github. com rcenvironnent/rce intoadirectory of your choice.



http://subclipse.tigris.org/
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Note

The clone settings of certain Git clients (e.g. TortoiseGit), have an "LFS" option. Make sure that this option
is enabled before you clone.

¢ Check out the mast er branch; by default, this points to the source code of the latest release.

« In Eclipse, select "File > Import > Genera > Existing Projects into Workspace" and choose the
directory that you unpacked the archivesinto. Y ou should see along list of projects, once again,
all except one beginning with "de.rcenvironment”. Select al projects confirm the import.

Note

Make sure not to change the " Search for nested projects' option in theimport dialog; it must not be selected/
checked.

« After you have successfully imported the RCE projects using one of the above methods, the next
stepisto set the RCE target platform in your workspace. A target platform providesexternal artifacts
like the Eclipse RCP framework and various libraries. To get started with RCE development, the
easiest way isto use a precompiled target platform. For convenience, there is a Eclipse .target file
insidethe code basethat always points at an appropriate precompil ed target platform rel ease. Follow
these stepsto apply it:

« In the Project Explorer, navigate to the de. rcenvi ronnment/eclipse/tp/renote
folder.

e Openthedefaul t _rel ease_or_snapshot .t ar get fileby double-clickingit.

» Select the "Locations' list entry starting with "ht t ps: // sof tware. dl r. de/ " and click
"Update'. After awhile, the list entry's description should end with something similar to "242
plugins available" (the exact number may vary). Save thefile if necessary.

» Click "Set astarget platform" in the top right corner. Y ou can close the .target file after this.

* If you previously changed the global Java compiler compliance level to 1.7 for previous RCE
releases, it is recommended to revert this setting to default, or explicitly set it to 1.8. This setting
can be accessed by opening "Window > Preferences’ from the menu, and then navigating to the
"Java > Compiler" tab. If you never actively changed this setting, no action is required.

e Enable "Project > Build Automatically". Eclipse will start building all projects against the new
target platform, which provides al required libraries and OSGi bundles.

« At this point, most projects will have a red error marker. To fix this, open the "Problems" view
("Window > Show View > Problems"). You should see a lot of "Plugin execution not covered
by lifecycle configuration” entries. Right-click one of them, select "Quick Fix" from the context
menu, select "Discover new m2e connectors” and click "Finish". Eclipse should present one or more
installation options with "Tycho" in their name. Confirm their installation and restart eclipse.

Note

Y ou only need to do this once per Eclipse installation.

 After this, all RCE bundles should compile without errors (with the exceptions noted below), and
you are ready to start developing. If thisis not the case, try running "Project > Clean > Clean al
projects” from the main menu.
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2.1.4.

Note

On Linux platforms, there will be compilation errors in some Windows-only Excel and TiGLViewer bundles
(5 and 3 projects, respectively). We don't have an elegant solution for this problem yet. Y ou can smply close
these projects to get rid of the errors, as they won't be loaded at runtime anyway.

Running RCE from Eclipse

Before proceeding to the more detailled settings, try running RCE from Eclipse to verify your setup.

» There are several pre-defined launch configurations for RCE. To find them, navigate to
de.rcenvironnent/ ecl i pse/l aunch inthe"Project Explorer" on the left.

* A good starting point isthe "default" configuration. Expand the "default" sub-folder, right-click the
"rce.default.launch” file and choose "Run As > rce.default.launch” from the context menu.

* RCE should now start and prompt for an RCE workspace location. Confirm the default value or
choose another empty folder.

Configuring Workspace Mechanic (optional)

Note

The Workspace Mechanic project initsoriginal formisnot being maintained anymore, and the original project site
isgone. However, it has been forked and is being continued by anew maintainer at thislocation [https://github.com/
afsch/workspacemechanic/]. While this is not an "official" successor, it seems to be the de-facto location of this
project now.

Workspace Mechanic (which can be installed via Eclipse Marketplace from this location [https:/
marketplace.eclipse.org/content/workspace-mechanic]) is an Eclipse plugin that automates common
settings in local workspaces. For RCE, the most important settings are the Java code formatting rules
and templates. Other settings are provided for convenience, like disabling the console output limit, or
showing line numbers in the editor.

Configuring Workspace Mechanic consists of copying a set of "rule” files to a location where the
plugin can find them. There are two options for this:

o If you want to apply the rules to al Eclipse installations on your machine, use the
.ecl i pse/ mechani ¢ subfolder in your home directory; by default, this is / home/ <user
i d>/.eclipse/ mechanic.

» To apply the rules to a single Eclipse installation only, use <ecli pse installation
f ol der>/ confi guration/ com googl e. ecl i pse. mechani ¢/ nechani c.

Using your system'sfile browser, navigate to the folder of your choice. Using any SV N tool, check out
https://svn.sistec.dlr.de/svn/rcel/ new metal/ ecli pse/ mechani c into a sub-
folder called "checkout " withinit. (Note that the actual name of the sub-folder is not relevant; adapt
if you like.) This sub-folder now contains common rules on itstop level, and optional or experimental
rules in sub-folders. Copy all common rules to the parent folder (the one you started in), and add any
optional rules that you want to apply aswell. (TODO add and describe batch/shell files for this.)

Note

These rule fileswill most likely be integrated into the main project at some point, making this extra checkout step
unnecessary. Please note that these rule files are currently not available as part of the GitHub source code mirror
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[https://github.com/rcenvironment/rce] or the rel eased source zip files either, which makesthem inaccessible unless
you have access to the internal SVN server.

The next time you open a workspace, Workspace Mechanic should pick up these rule files and
show a notice asking if it should apply them. See the plugin's web site [https://github.com/alfsch/
workspacemechanic/] for further information.

Configuring Code Formatting and CheckStyle

Rules (optional)

2.1.6.

If you only plan to try out or modify RCE locally, you can safely skip this section. If you plan to
commit your changes to the central code base, however, you need these settings to get your code
accepted into the repository. Code that does not match the style guidelines will be refused on commit.
The Checkstyle-CS plugin simplifies development by highlighting violations that need to be fixed.

To configure Checkstyle-CS for RCE:
» Open the Checkstyle preferences (Window > Preferences > Checkstyle).
e Click "New" on theright side. Enter "RCE" as the name of the configuration.

» Choose "Project relative configuration”, click "Browse" and choose de. r cenvi r onment /
checkstyl e/ checks. xm .

* Click "OKk" in the main dialog. The list of configurations should now have three entries; select
"RCE" and click "Set as Default" on the right side.

* Close the preferences with "Ok" and confirm the rebuild.

Note

Weare currently using version 6.19 of the Eclipse CheckStyle plugin within the development team. Using anewer
version (e.g. 8.0) works aswell, but you may see error markers for constructs that do not actually violate the RCE
code guidelines. Versions > 8.0 do not work with current code guidelines. We will most likely adapt/migrate the
CheckStyle settings in the near future.

To configure the Eclipse source code formatter:
» Open the code formatter preferences (Window > Preferences > Java > Code Style > Formatter).

» Click "Import", browse to your de. r cenvi ronnment / ecl i pse/ checkout folder and choose
the"ecl i pse-formatter. xm " file.

* You should now see "RCE" asthe "Active Profil€e".

e Click "Apply and Close" to activate the settings.

Note

There are rare cases where these code formatter settings lead to source files that are not being accepted by our
CheckStyle rules. These inconsistencies are being collected and tracked in issue #0005898, and will be fixed/
addressed in a future update.

Building a standalone RCE version from Eclipse

Y ou can a'so build a standalone version of RCE from Eclipse using Maven.

e There are several pre-defined build configurations for RCE. To find them, navigate to
de. rcenvironnent/ ecl i pse/ bui | dinthe"Project Explorer" on the left.
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e Torun a.launch file, right-click on it and choose the single entry in the "Run As' submenu of the

context menu that appears.

» Building astandalone RCE installation (whichiscalled a"product” in Eclipse RCPterms) generally

consists of two steps: Providing a so-called "platform repository”, and then building the actual
product on top of it. There are two possible approaches for this:

e Using the .launch filesinthe "usi ng default renote repository buil ds" sub-
folder, it is possible to avoid building your own platform repository, and fetch a pre-built one
from the main repository servers (currently hosted at DLR) instead. One reason for this can be
be to ensure that you are building against the exact same platform repository as a certain RCE
release. Another reason is to simplify your local development setup if you have no reason to
customize the target platform setup (e.g. by adding libraries).

» Themost flexibleway to build RCE from sourceisto compilealocal platform repository yourself.
This is simply done by navigaring to the "de. r cenvi r onment . pl at f or mf ecl i pse
folder (from the root of your workspace) and executing the single .launch file that is located
there. On the first run, the build process may download quite a few resources from Maven
Central; subsequent runs should be fairly quick. Once the build has finished (there should be a
"SUCCESS" message near the bottom of the console output), you can build the main product
using the .launch files in the "usi ng | ocal repository buil ds" sub-folder of the
previously mentioned |ocation.

» Regardless of whether you use a pre-build platform repository or compile one locally, running the

"RCE - build default product (snapshot, using <...>) .aunchfileisthe
best way to produce a standard local product build. The other .launch files are intended for more
specific use cases.

e The main product build takes several minutes to complete. Once it has finished, you will

find the .zip files containing the fina product in the folder de. r cenvi ronment/ t ar get/
de. rcenvi ronnent . nodul es. reposi tory. mai nProduct/products (You may
have to refresh the de.rcenvironment project in the Project Explorer to seeit.)

Building from the command line

Building RCE completely from the command line is somewhat complicated as it is a multi-step
processin which later steps must reference the output artifacts of previous steps. To simplify this, the

command-line build will be further encapsulated by front-end scripts, which will then be documented
here. In the meantime, please use the steps described above to trigger the build process from Eclipse.

Note that both the Eclipse-based and the command-line build trigger the same Maven steps in the
background. Because of this, the build triggered from Eclipse produces the exact same artifacts as a
command-line build (which is used in Continuous I ntegration and for releases).

Note

TODO document the new command-line build when ready

2.2. Common Classes and Interfaces

This section lists classes and interfaces that every RCE developer should be familiar with.

Note that at this point, thislist is probably incomplete. If you come across a class you wish you had
known earlier, please let us know.




Introduction

2.2.1.

2.2.2.

2.2.3.

General

ResolvableNodeld,
InstanceNodeld,
InstanceNodeSessionld,
LogicaNodeld,
LogicaNodeSessionld (former:
Nodel dentifier)

Explanation for Nodeldentifier: This interface represents the
"identity" of anode, and is used whenever nodes are specified
in API calls. In general, these node identifiers (or "node ids")
are stored and reused by nodes, so they are persistent unlessthe
node's operator deletes its settings folder. From a developer's
perspective, theinner format of theseidsisusually not relevant.

TODO: Replace with explanation referring to current node
identifier approach

Package: de.rcenvironment.core.communication.common

Components and Workflows

TypedDatum  Represents a chunk of data that is passed between the components of a workflow.
Thisisthe central abstraction of all data passing, so you will encounter it when you
start writing or modifying workflow components.

Package: de.rcenvironment.core.component.datamodel (Note: may be moved in

5.0.0)

Utilities

ThreadPool/SharedThreadPool

TempFileUtils

This is a centra thread pool that should be used for all
asynchronous operations (except for the SWT GUI thread
itself, and GUI-embedded "background tasks'). Always use
this instead of creating Thread or Executor/ExecutorService
instances.

(TODO add code example(s), explain @TaskDescription, ...)
Package: de.rcenvironment.core.utils.common.concurrent

This utility class should be used whenever atemporary file or
directory should be created. Its main benefit is that it alows
for managed cleanup of leftover temporary files/directories
(Note: This is not yet implemented!). Additional benefits
are convenience functions (like generating a temporary file
with a given filename or name pattern), central handling of
cleanup issues (like undel etable files), and making sure that all
temporary files are created in a consistent location.

Package: de.rcenvironment.commons (Note: will be moved in
5.0.0)




Chapter 3. Build and Infrastructure

3.1. Build Structure and Dependencies

3.1.1. Overview: Build and Versioning Scopes

TODO migrate/add content

3.1.2. Changing Version Dependencies
3.1.2.1. Switching "RCE Core" to another version of "RCE
Platform”

TODO migrate/add content

3.2. Release and Versioning Process

3.2.1. Overview: The Release and Versioning Process

Creating an RCE release and preparing for the next oneis a process that can be split into four distinct
steps (or phases):

» Trunk preparations - actions that take place in the development trunk before the release branch is
split off.

» Release candidate building and testing - creation of the release branch, building RCs on the CI
server, and applying fixesif necessary.

* Final release - creating and publishing thefinal release build, SCM tagging, posting announcements
etc.

* Post-release actions - preparing the trunk for the next release.

3.2.2. Step 1: Trunk preparations

TODO migrate/add content

3.2.3. Step 2: Release candidate building and testing

TODO migrate/add content
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3.2.4.

3.2.5.

Step 3: Publishing the final release

TODO migrate/add content

Step 4: Post-release actions

3.2.5.1. Upgrading Version Numbers (and Verification)

3.2.6.

By convention, the version numbers of al plugins and features are increased in the trunk immediately
after a release has been performed. This way, every snapshot build is associated with the
upcoming release. For example, all snapshot builds after the 8.1.0 release should be named named
"8.2.0.xxx_SNAPSHOT".

The version upgrade process of RCE Core is mostly automated:

* Open ashell or command window in "/de.rcenvironment.core/maven/utils/" and run the appropriate
"upgrade-core" script for your platform (.bat on Windows, .sh on Linux). Usage:

upgrade-core{old core version} {new core version}
Example: upgr ade-core 8.0.0 8.1.0

« Build the platform repository and the full product locally to verify that the build setup is consistent;
see the "getting started" section on how to do this.

e Create aMantisissue "release x.y.z" for the new version if it does not exist yet (usually, it won't).
» Commit the changes under thisissue.
» Verify the Cl/Jenkins build
¢ (Option 1) TODO update this section for 8.1.0+
< (Option 2) Keep an eye on the standard periodic builds (nightly, "onCommit", ..) and see if they
complete normally. IMPORTANT: Thisis ONLY appropriate if you are around/available for

handling possible problems!

If the platform will change in the upcoming release, it is also necessary to upgrade the version of the
platform projects. However, we do not upgrade the platform version automatically with every RCE
release (for example RCE 8.2.0 till usesthe 8.1.0 platform, as there were no changes in the platform
between these rel eases).

The version upgrade process for the platform projectsis also mostly automated:

* Open a shell or command window in "/de.rcenvironment.platform/maven/utils/” and run the
"upgrade-version" script. Usage:

upgrade-version{old core version}{new core version}

Example: upgr ade-version 8.1.0 9.0.0

Creating a maintenance/hotfix release

When creating a release that is not based on the current development trunk, the release process is
dightly different. Such "maintenance” or "hotfix" releases must always be derived from a stable
release.

11
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To create anew release based on a previoudly-released version:;

Create arelease branch (similar to a normal release) by copying the SVN release tag folder.
Check out this release branch to your local machine.

Asin step 4 of the standard process, upgrade the local version numbers, create a Mantis issue for
the release and commit the version changesto it. Note the change in ordering: in astandard release,
version numbers are upgraded in the trunk after the release; in a maintenance/hotfix release, they
are upgraded before the release, inside the release branch.

Apply and commit thefixes or changes you want in therelease; if you want to include specific trunk
changes, consider transfering them by using diff patches.

Perform standard step 2 (RC building and testing).
When everything is tested, perform standard step 3 (final release).

If changes were made in the release branch that should aso be in the trunk, merge them back
selectively . Unlike a normal release, you cannot simply merge all branch changes back to trunk;
take specia care not to mix up version numbers when merging.

3.3. Build Process FAQ / Tips and Tricks

This section gives answers and hints to common build issues.

Q:
A:

After running alocal product build, where do | find the generated product zips and files?

The  generated files are located in de.rcenvironnent/target/
de. rcenvi ronnent . nodul es. reposi t ory. mai nProduct/ products .

When running a product build, how can | change the server URL where p2 artifacts (e.g. the
"target platform") are loaded from?

To support typical build use cases, p2 server URLSs are normally assembled from two parts:
a common URL "root" part, and a repository-specific URL segment. The default values
for these are defined in the build pre-processor script at / de. r cenvi r onnent / maven/
preprocessor/ scri pts/ RCEBui | dPreprocessor. groovy .

Note

For example, the default "target platform" repository URL for the 8.1.0 release is the concatenation of the
default URL "root" part htt ps://software. dl r.de/ updates/rce/ 8. x/repositories/

and the specific repository segmentr el eases/ 8. 1. 0. The same pattern using the same"root" URL, but
different specific segments would also be used for other repositories. However, as of 8.1.0, the "platform"
repository isthe only one used during the default build. Theonly other valid optionis"intermediate”, which
isonly used in special builds.

There are three ways to change these URLs, depending on the build use case.

e If you want to switch to a different server that provides al of the required
repositories, you can simply override the URL "root" part, and all p2 repositories
will be loaded from there. This can be done by setting the Maven property
rce. maven.repositories.default.rootUrl.

* To overide the URL root path of a single repository, set the Maven property
rce. maven.repositories.<id>rootUl, with <id> beng "plaform" or
"intermediate”.

12
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« Alternatively, you can also override the complete URL of arepository by setting the Maven
property r ce. maven. reposi tori es. <i d>. ur| with the sameids as above.

All of these settings can be combined, with more specific settings overriding the more general
ones (e.g. acustom repository URL overrides a custom root URL).

Note that these approaches are only intended for adapting the build to your build
environment, or for local building and testing. To change the repository paths
permanently (e.g. when preparing a new release), edit the default values in the build
pre-processor script at / de. rcenvi ronnment/ maven/ preprocessor/ scripts/
RCEBui | dPr epr ocessor . gr oovy. Notethat therearetwo setsof specific repository URL
segments which are used for snapshot and RC/release builds, respectively.

| created a new snapshot / RC / release build of the "platform™ repository. What do | have to
edit to make the product build useit?

The default repository references are configured in the
def aul t Reposi toryUr | Suf fi xes map within the build pre-
processor script  at  /de.rcenvironnment/ maven/ preprocessor/scripts/
RCEBui | dPr epr ocessor. gr oovy. Snapshot and RC/release references are configured
separately to support developing against snapshot builds. These references are the repository-
specific URL suffixes; see the question above for examples.

Note that when preparing for a new major release, you may aso have to adapt the "root" URL
part (e.g. changing it from <. ..>/rce/ 8. x/repositories/ to<...>/rce/9.x/
reposi tories/), and haveto deploy the referenced repository builds to that new location.
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Chapter 4. Coding Guidelines

4.1. Developing a new Component

4.1.1.

4.1.2.

Component Bundle Setup

An RCE component usually consists of up to three OSGi bundles. named the execution, gui, and
common bundles:

» Execution: Contains the component's lifecycle.

* GUI: Contains the user interface to configure the component. If a component does not require a
user interface this bundle can be ommitted.

» Common: Contains code resources which are used by both the execution and the GUI bundle. This
bundleis optional, too.

Note that in the context of Eclipse, OSGi bundles are called Plug-In Projects, and can be extended
with Eclipse-specific features. In practice, the terms bundle and plugin are often used interchangeably.

Creating the execution Bundle

To start developing your first component, generate a new Eclipse Plug-In Project by selecting the
corresponding item in the menu bar:

File | Edit Source Refactor Mavigate Search Project Run Window Help

New Alt+Shift+MN ¥ | IgZ Plug-in Project
Open File... 4% Feature Project
Close Ctew | [ Project..
Close All Ctrl+Shift+W (T Task
Save Ctrl+S o]  Component Definition
B Savehs gl Product Configuration
S saveal Cirtestuptes | 1) | Target Defnition
Revert f¥ Package
(& Class
Rlotes & Interface
= |
[ Rename.. 2 & Source Folder
b
# Refresh F5 % File I
Convert Line Delimiters To 3 &% | Folder
Print... Ctrl+P Y Example. |
Switch Workspace 3 E% Other.. ChrlN
Restart -
f2g Import... |
By Export... :
Properties Alt+Enter |

1 WizardToolCenfiguraticnDialog.java

2 daketaSGBlocaljsen [dercenvironme..]

|
|
|
]
3 OptimizerComponentCenstants.java [d..] |
4 daketaDOE_LHC jsen [dercenvironmen...] .

|

|

Exit
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Fill in the dialog properties to configure the plug-in project. The name of the new
project should match the RCE naming conventions. That means it should start with
"de.rcenvironment.components.” and end with ".execution"; so the full name of the execution
bundle should be "de.rcenvironment.components.<your conponenti d>.execution", where
<your conponent i d> isthe ID of your new component. Change the property "Source folder" to
"src/main/java’ and "Output folder" to "target”. Proceed by clicking "Next >".

= Mew Plug-in Project = &

Plug-in Project = L
Create a new plug-in project

Project name:  dercenvironment.compenents.yourcoemponentname.execution

Uze default location
C\Users\abbe_helworkspace\dercenvironment.compenent Browse...
Project Settings
Create a Java project
Source folder:  src/main/java

Output folder:  target

Target Platform
This plug-in is targeted to run with:

@ Eclipse version: 3.5 or greater -

(©) an O5Gi framework: | Equinox

Working sets
[7] Add project to working sets

Select...

@j < Back Mext » Finish

Now specify theversion of your component; you can choosethisfreely. The name of thisplugin should
always be "RCE Components <Your Conponent Name> Execution" for the execution bundle,
where<Your Conponent Name> again isyour component's display name. Pressthe "Finish" button
to complete the general configuration of this plugin.
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= Mew Plug-in Project

Content o J_ .
Enter the data required to generate the plug-in.

Properties

1D: de.rcenvironment.components.yourcomponentname. executior
Version: 3.2.0.qualifier

Mame: RCE Components YourCompenentName Execution

Vendor: -
Execution Environment: |JavaSE-1.6 v] IEnvironments...
Options

[7] Generate an activator, a Java class that controls the plug-in's life cycle
de.rcenvironment.compenents.yourcomponentname.execution. Activator

[] This plug-in will make contributions to the UI
[T Enable API analysis

Rich Client Application

Would you like to create a 3.x rich client application? I ¥es @ No

@ | <Back | Net> |[ Fnish || Cancel |

Eclipse now creates the configured structure of folders, but the plugin is not ready for being used as
an RCE component yet.

Create a folder called "resources' in the project you just created. If you have icon files
for your component, put them into this folder. Supported formats are PNG, JPG, BMP and
GIF. We recommend a resolution of 16x16 and 32x32 pixels. Conventionally these icons are
namend "<your conponent nane>16.png" and "<your conponent nane>32.png". Also create
an "inputsjson”, an "outputsjson" and a "configuration.json" file in the resource folder you just
created, where you later define the inputs, outputs and configuration of your component.

Asadtart, the files can contain an empty JSON object as content. So it suffices to enter the following
text in these threefiles:

03 |

Note that the files must be present and must not be empty.

Now create a Java class in your source folder by right-clicking on "src/main/java’ in the Eclipse
Project Explorer. As this will be the central class of your component, give it a name like
"<Your Conponent Nane>Component.java' (<Your Conponent Name> is your component's
display name in camel case, and then add "Component.java'). This Java class must extend
de. rcenvi ronnent . core. conponent . nodel . spi . Def aul t Conponent .

To implement the functionality of your component override the according methods. The most basic
methods to be overriden are:

« processlnput: Iscalled whenever the component receives anew input. Inloopsthis method iscalled
multiple times.

 dstart: Iscalled at component start once. Initializations can be placed here.

« dispose: Is called when the component disposes. Clean up methods can be placed here to release
resources.
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Now create a folder caled "OSA -1 NF" in your project folder, by using the standard
Eclipse function (File->New->Folder). This folder will contain al OSGi service definitions
for your project. One way to create an OSGi service definition is creating a file
"<your Conponent Nanme>.xml" ("<your Conponent Nane>" is your own component's display
name again) and copying the following source code into it. Replace al occurences of
"<your Conponent Nanme>" with the display name of your component, and all occurences of
"<your conponent nane>" withitsid:

<?xm version="1.0" encodi ng="UTF-8"?>
<scr:conponent xm ns:scr="http://ww.osgi.org/xm ns/scr/vl. 1. 0"
factory="de. rcenvironment.rce. conponent” nane="<your conponent name>">
<i npl enent ati on cl ass="de. rcenvi ronnent. conponent s. <your conponent nane>.
execut i on. <your Conponent Nane>Conponent " />
<service>
<provi de interface="de.rcenvironnent.core.conponent.registration.api.Registerable" />
</ service>
<property nane="rce.conponent.class" type="String" val ue="de.rcenvironnent.conponents.
<your conponent nane>. execut i on. <your Conponent Nane>Conponent" />
<property nanme="rce. conponent.version" type="String" value="1.0" />
<property name="rce. conponent.name" type="String" val ue="<yourconponent nane>" />
<property nane="rce.conponent.group" type="String" value="Test" />
<property nanme="rce.conponent.icon-16" type="String" val ue="/resources/your conponent nanel6. png" />
<property nane="rce.conponent.icon-32" type="String" val ue="/resources/yourconponent nane32. png" />
<property name="rce.conponent.inputs" type="String" val ue="/resources/inputs.json" />
<property nane="rce.conponent.outputs" type="String" val ue="/resources/outputs.json" />
<property name="rce. conponent.configuration" type="String" val ue="/resources/configuration.json" />
</ scr: conponent >

Some of these definitions are optional or refer to elements that do not exist yet. Thefirst lines provide
the general XML header, followed by the OSGi root element. Thef act or y attribute is the part that
links this definition into the RCE framework. The nane attribute defines your component's name
when inspected with OSGi tools and should be the same asther ce. conponent . nane property
below. Thei nmpl enent ati on cl ass entry defines the main Java class of the component. The
rce. component . gr oup property setsthe GUI group in which your component will appear. (Since
the component is still under development, something like "Test" is a good choice for now.) The
rce. component . i con- 16 andr ce- component . i con- 32 propertiesare optional and define
theicon for your component. Ther ce. conmponent . i nput s, r ce. conponent . out put s and
rce. component . confi gur at i on attributes define the locations of configuration files that will
be described later.

The created plugin project automatically contains a folder named "META-INF'. Edit the
"MANIFEST.INF" filein thisdirectory by double-clicking it and selecting the"MANIFEST.MF" tab.
Add the following lines to it and save:

Servi ce- Component: OSG - | NF/ *. xml
RCE- Conponent: true
Export - Package: de.rcenvironnment.conponents. <your component nane>. executi on

Note that "Export Package: " and the first name have to be in the sameline. A second element would
be added in the next line with aleading space. Moreover the file must end with alinebreak.

Also note that errors containing "inconsistent hierarchies' can be solved by adding the required
referenced packages in the Import-Package property anal ogous to the Export-Package property.

Thefirst linetellsthe OSGi framework whereto look for the component declaration we created before.
The second line declares this plug-in as an RCE component. The last line makes the package of your
main class visible to other bundles, which is required so RCE can load and initialized the component.

Next, edit the "build.properties’ filein the main folder of your plugin project. This file should aways
look the same for the execution bundles and can be copied from the sample component. It should
look like this:

source.. = src/main/java
bi n.includes = META-| NF/,\
OSA - I NF/, \

resources/,\
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After this step, the plugin configuration is complete. It should look like this in the Eclipse Package
Explorer:

‘,'7‘J dercenvirenment.components.yourcomponentname.execution
» = JRE System Library [JavaSE-1.6]
4 B sre/main/java
a f}} dercenvironment.components.yourcomponentname.execution
- [J] YourComponenthameCompenentjava
4 = META-INF
4+ MANIFEST.MF
4 = OSGIINF
@l yourComponentMame.xml
4 (= resources
Configuration.json
Inputs.json
Qutputs.json
| yourcomponentnamel6.png
B yourcompeonentname3d2.png
= src
‘b build.properties

When you start RCE from Eclipse and open aworkflow file, your component should be shown in the
component pal ette on the right, in the group that you have set in the "OSGI-INF/..." XML file.

4.1.3. Creating a common Bundle

Generate a new Eclipse Plug-In Project by selecting the same option as in the "execution" bundle
section above. The project name should follow the RCE naming conventions, similar to the execution
bundle but ending with ".common" instead of ".execution”.

Add the Java classes to the source folder, within a package with the same name as the bundle's name
(or sub-packages of it). For holding shared constants, the usual convention is a Java class named
"<Your Conmponent Nanme>ComponentConstants.java". Createthisclass, and add your first constant
for defining the component id and adapt the placeholders in the usual manner:

public static final String COVPONENT_I D =
"de. rcenvi ronment . conponent s. <your conponent nane>
execut i on. <Your Conponent Name>Conponent " ;

In order to keep track of your constants, it's advisable to give al constants a short comment.

To complete the setup, add the names of the all Java packages you created to the "Export-Package"
attribute in the source code of the META-INF/MANIFEST.MF file. Example:

Export - Package: de.rcenvironnent. conponents. <your conponent name>. conmon

4.1.4. Creating a gui Bundle

To add agraphical user interface for your component, create a"gui" bundle. Start by generating a new
blank Eclipse Plug-In Project, as you did for the "execution" and "common" bundle.

The graphical user interface is shown in the properties tab which is usually shown at the bottom of
RCE when the component is focused in the workflow editor.

Custom sections can be defined. Therefore create a package called like the project containing it.

Inside the package create a class called "<Your Comrponent Nane>Section.java' which extends

de. rcenvironnent. core. gui . wor kf | ow. edi t or. properties. Wrkfl owNodePr opertySecti o
Override the method cr eat eConposi t eCont ent to fill the GUI.
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Each component GUI must provide a Component Filter. It is used to determine which
sections the GUI for the respective component consists of. Inside the package you
just created add a class caled "<Your Conponent Nane>ComponentFilter.java'. extending
de. rcenvironnent. core. gui . wor kf | ow. edi tor. properties. ConponentFilter.
To define the component filter, override the following method:

@verride
public bool ean filterConponent Name(String conponentld) {
return conponent!d. startsWth(Your Conponent NaneConponent Const ant s. COMPONENT_I D) ;

}

As usual, change Your Conrponent Nane to the name of your own component. This method will
only return t r ue for the component id used in the "execution" bundle, so it will only be shown for
that component.

To provide sections as GUI elements, add a new file called "plugin.xml" to the root of the project
folder. It is common to have a section where you can manage inputs and outputs and another section
where component specific GUI elements arelocated. The following code demonstrates thisand can be
pasted into the plugin.xml you just created. Asusual, adapt the component names and I Dsaccordingly.
It is explained below:

<?xm version="1.0" encodi ng="UTF-8"?>
<?ecl i pse version="3.2"?>
<pl ugi n>

<l-- Property Sections -->

<ext ensi on point="org.eclipse.ui.views.properties.tabbed. propertySections">
<propertySections contributorld=
"de. rcenvironnent.rce. gui . wor kf | ow. edi t or. Wor kf | owEdi t or " >

<propertySection
tab=
"wor kf | ow. edi t or. t ab. <your conponent i d>. General "
class=
"de. rcenvi ronnment . conponent s. <your conponent i d>.
gui . <your Conponent Nane>Secti on"
id=
"wor kf | ow. edi tor.tab. Properties. Section. General "
filter=
"de. rcenvi ronment. conponent s. <your conponent i d>.
gui . <your Conponent Nane>Conponent Fi | ter"
enabl esFor="1">

</ propertySection>

<propertySection
tab=
"wor kf | ow. edi t or. t ab. <your conponent i d>. | nput sQut put s"
class=
"de. rcenvi ronnent. core. gui . wor kf | ow. edi tor.
properties. Def aul t Endpoi nt PropertySecti on”
id=
"wor kf | ow. edi tor.tab. Properties. Section. | nput sQut puts"
filter=
"de. rcenvi ronnment. conponent s. <your conponent i d>.
gui . <your Conponent Nane>Conponent Fi | ter"
enabl esFor =
"1t >
</ propertySection>

</ propertySections>
</ ext ensi on>

<l-- Register Property Sections -->

<extension point="org.eclipse.ui.views.properties.tabbed. propertyTabs">
<propertyTabs contributorld=
"de. rcenvironnment.rce. gui . workfl ow. edi t or. Wr kf | owEdi t or ">

<propertyTab
| abel =" General "
cat egory="defaul t"
i d="wor kf | ow. edi tor. t ab. <your conponent i d>. Gener al ">
</ propertyTab>

<propertyTab

| abel =" nput s/ Qut put s"

cat egory="defaul t"

i d="wor kf | ow. edi t or. t ab. <your conponenti d>. | nput sQut put s" >
</ propertyTab>
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4.1.5.

</ propertyTabs>
</ ext ensi on>

</ pl ugi n>

For each section that you would like to add to the " Properties" view, add the entrieslike you can seein
the propertySection and the property Tab parts. Make sure that the "filter" attribute contains the correct
path of the component filter class created above. The first entry in property section and property tab
adds a general custom section to the GUI while the second entry adds a section to manage inputs and
outputs.

Remember to keep the file valid by closing the definition blocks with the corresponding end tags:
After assigning the property tabsto their classes, you have to register each tab asapr oper t yTab.

Note that the ID of the propertyTab should be the same as the "tab" in the propertySection above.
Customise the section title by editing the | abel attribute.

TODO: Add explanation how to use Messagesfile.

Adding your new component to SVN

It is recommended to develop a new component in a separate development branch. Therefore create
a new branch. One of the several ways to do so is using TortoiseSVN. Check out the trunk. In the
context menu of this folder select "TortoiseSVN > Branch/Tag". Navigate to the destination path
which should be located in the branches folder. Call the new branch "dev_Your Conponent Nane"
where Your Conponent Narre is the display name of your component. Then add the folders of the
projects you created above to the structure in your file system. Select them and right click to open the
context menu. Then select "TortoiseSVN > Add...". To commit them into the branch, open the context
menu again and select "Commit... ".

4.2.Logging

4.2.1.

4.2.2.

General Configuration

(TODO)

Verbose Logging

Some log messages are disabled by default as they produce large amounts of output, and are only
needed in special circumstances (typically, for debugging). Thisis called "verbose logging”, and is
controlled by the DebugSet t i ngs utility class. Typical usageisto initialize afinal (static or non-
static) field in the logging class with the returned setting, to only incur the configuration checking
overhead once:

* non-static field (preferred in most cases, as there is no risk of copying/pasting with
the wrong class parameter): private final bool ean verboselLogging =
DebugSet ti ngs. get Ver boselLoggi ngEnabl ed(get d ass());

o satic field / constant (preferred for classes that are instantiated very frequently):
private static final bool ean VERBCSE LOGE NG =
DebugSet ti ngs. get Ver boselLoggi ngEnabl ed( TheCl assNan®. cl ass) ;
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To control the verbose logging, set the rce.verboselLogging system
property. Example rce -p myProfile -vnar gs -
Drce. ver boselLoggi ng=*. NodePr operti esServi cel npl, *Wor kf | ow*. The syntax
of the pattern is a commarseparated list of identifiers. A "*" wildcard matches any part of the class
name, including the dot ("."). An empty string disables all verbose logging.

Note

Aswith any other VM property, this parameter must be placed behind the - vimar gs delimiter, which separatesit
from the "direct" RCE command-line arguments (like - - headl ess or-p <profi | e>). Thisruleaso applies
when adding this parameter toanr ce. i ni file.

If this system property is not Set, the
DebugSet ti ngs. DEFAULT_VERBOSE LOGE NG _PATTERN constant's value is used. While
developing in Eclipse, it can be useful to enter a verbose logging pattern there, as this affects all
local RCE instances at once without editing multiple launch configurations. (As usual, it is your
responsibility to make sure these local debug values are not commited into version control.)

Identifiers created before 8.1.0 were fully qualified Java class names; since 8.1.0, identifiers are
arbitrary strings. For existing identifiers, these strings were set to the pre-8.1.0 FQNs. Over time, al
existing identifiers are planned to be migrated to more intuitive strings.

The following table lists some identifiers that may be useful for debugging:

Table4.1. Useful Verbose Logging Identifiers

Identifier Description

NetworkRequests outgoing and received network requests and
responses, and possibly other related operations
(e.g. conversions)
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Chapter 5. Quality Assurance and
Testing

5.1. Automated GUI Testing

5.1.1. Getting started

This section describes the required steps to run existing or create new automated GUI tests for RCE
using the RCP Testing Tools (RCPTT):

Download RCPTT from https://eclipse.org/rcptt/download/
Download RCE from https://rcenvironment.de/pages/downl oad.html
Start RCPTT

In the view "Applications' add RCE as Application under test (AUT) via "New... ". Use RCE's
main folder as location.

Configure AUT (Rightclick on entry in "Applications" view -> Configure... -> Advanced...):

. Set aprofiledifferent from the default one to make sure your productive RCEswon't interferewith

RCPTT's RCE and vice versa. Therefore go to "Arguments' tab and add to Program arguments
e.g"-p my_rcptt_profile".

. Set dev_config: Download from dev_config.ini from https://svn.sistec.dlr.de/svn/rce/new/rce/

trunk/de.rcenvironment/eclipse/launch/installation_datal  [https://svn.sistec.dir.de/svn/rce/new/
rce/trunk/de.rcenvironment/eclipse/launch/installation_data/dev_config.ini]

In"Configuration" tab select "Use an existing config.ini file as atemplate” and navigate to the file
you just downloaded.

. Set launcher: In  "Arguments' tab add the following VM argument: "-

Dde.rcenvironment.launcher=de.rcenvironment.launcher"

. Set allocate console for Stdin and StdOut: To access Stdin and StdOut directly from console

view in RCPTT go to "Common" tab and check "Allocate console (necessary for input)
Check if RCE can be started from RCPTT by doubleclicking ontheentry inthe"Applications" view

Now you can either run existing test cases (A) or create your own test cases (B):

A: Run existing test cases:

Create an RCP Testing Tool Project in the Test Explorer on the lefthand side

Checkout the following folder and add it to the project: https://svn.sistec.dIr.de/svn/rce/new/rce/
trunk/de.rcenvironment/eclipse/ui-testing/RCPTT

In the folder "Testsuites' navigate to "AllPlatforms" and execute the testsuite (Rightclick -> Run
As-> Test Cases)
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* Find the Execution View on the bottom left which shows the progress of the testcases
» Do the same for the testsuite that matches your platform.
B: Createyour own test cases:

e For the next steps also refer to RCPTT's getting started guide: https.//www.eclipse.org/rcptt/
documentation/userguide/getstarted/

» Create an RCP Testing Tool Project inthe Test Explorer on the lefthand side
» Create aTest Casewithin this project
» Capturescript via"Record" button in the upper right corner and then clicking around in RCE

e Capture verification by switching to Assertion Mode in the menu bar of the Control Panel and
then selecting some element in RCE

* Click save, stopp and then the Return to RCPTT/Home button

» Create a Context within the project (New -> Context). Contexts are proconditions for tests, e.g. to
make sure there is a clean setup. For instance, choose a context of type "Workspace" an leave the
default settings so it will clear the workspace upon being applied.

» Add the context to the test case by selecting the " Contexts' tab in the test case, click "+" and choose
the one you just created.

* Replay script by clicking "Replay” in the upper right corner.

5.2. Integrated Test Script Runner

5.2.1.

The integrated "Test Script Runner" (TSR) was created to automate test sequences on one or more
RCE standaloneinstallations. These installations are automatically set up using an RCE feature called
"Instance Management” (IM), which is still under development, and therefore not fully documented
yet. However, the instructions below should be sufficient to configure this feature as needed for the
TSR.

Asof RCE 9.0.0, the Test Script Runner isincluded in the standard application release, aswell asthe
standard Eclipse checkout. Therefore, very little configuration is required to useit.

Configuration

The only configuration that is reguired for using the TSR is adding an Instance Management
configuration to the RCE instance that will execute the test scripts. This defines the root directory
where work files and directories of managed RCE test installations will be stored. Locate the profile
directory that is being launched and edit its confi gur ati on. j son file. In this file, add this
configuration block on the root JSON level, and adjust the settings as necessary:

"i nstanceManagenent": {
"dataRootDirectory": "/tnp/rce-i mdat"

}

Note that there are additional Instance Management configuration parameters available; however,
these are not usually needed for using the TSR.
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Note

Itisstrongly recommended to use ashort full filesystem path asthedat aRoot Di r ect or y, asRCE installations
will be placed inside of it, and long filesystem paths are known to cause problems with these. The exact maximum
lenght will be determined, documented, and maybe also automatically checked in the future.

5.2.2. Usage

The TSR is invoked by a single RCE console command (r un-t est ), with an alias for readability
(run-tests). Thegenera syntax is:

run-test[s] <conmma-separated list of test ids> --all <build id>
There are three typical scenarios for calling this command:

 from within an RCE instance launched from Eclipse during development, usually using the GUI
workflow console

« from within a standalone RCE instance, also usually using the GUI workflow console
» asaClLl batchrun(rce --batch "...") usingastandaloneinstance.

The RCE ingtallation to be tested is defined by the <bui | d i d> parameter in the above command.
One important aspect to understand is that thisinstallation is generally independent of the installation
being used to execute the TSR command. The latter is, in asense, only the "host" of test scripts. There
are three ways of specifying the build to test:

1. A build download id, which corresponds to a certain part of the standard download URL, for
examplesnapshot s/ trunk orr el eases/ 9. 0. 0. The structure should be self-explanatory.
(The major release tree to use for snapshot builds is one of the optional Instance Management
settings mentioned above; the default isto use the current major version, ie 9.x.)

2. A path to an unpacked local standalone (product) build, which can, for example, result from alocal
build run or from unpacking adownloaded product zip file. The syntax for thisis| ocal : <l ocal
i nstallation path>. Thisdirectory can be either writable or read-only. For example, it is
also possible to test a (read-only) .deb or .rpm package installation this way.

Note that this path must point to an already-unpacked RCE build, unlike the first approach, which
downloads zipped release packages and unpacks them automatically.

3. As it is a frequent use case when testing standalone builds to execute the test command the
installation itself, there is a convenient shortcut for this. By specifying : sel f asthebuildid, the
test scripts are executed on the installation of the instance used to run the test command.

Note that due to technical limitations, however, this shortcut is not possible when launching RCE
from Eclipse, asthe test scripts require a standard product build to execute.

The actual test scripts are located in * feature files
in the / de. rcenvironnment. suppl enental . testscriptrunner.scripts/
resources/ scri pt s directory. The"testids" in the command description are the annotation-like
tags abovetheindivual test scenarios, e.g. "@TestO1". These can be specified in the command with or
without the" @" character."- - al | " executesall availabletest scenarios. Thereserved " @i sabl ed"
and"@li sabl ed" tags can be used to mark tests as excluded inthe* . f eat ur e files.

5.2.3. Examples
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run-test Test02, Test04 snapshots/trunk - runs two specific tests on the latest
snapshot build

run-test Defaul t TestSuite :self -runsthedefault collection of tests on the current
installation

run-test --all local:/tnp/local-rce-build -runsall available tests on alocal
build

rce --batch "run-test DefaultTestSuite :self" -thefull command linefor the
standard self-test of an installation
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Chapter 6. Licensing and Copyright

6.1. Copyright Statements

6.1.1. Current Year Definition

In copyright statements, the current year is defined. Each year, it must be updated at the following
places (files):

 Header in Java sourcefiles
« featurexml files
» About dialog (de.rcenvironment.core.start/about.mappings)

 Splash images ([..].gui.branding.[..]/splash.bmp)
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